A problem for the spice boys

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Mon Feb 18, 2008 9:48 am

Sparkle
I like your analogy of viewing input impedance as a function of power consumed/ power reflected. I hadn't given much thought to that aspect. Just for the record as it stands now ~ RF in is +6dbm (as best as I can measure) and quite distorted; LO in is 0 (not to be confused as 0DBM). IF port terminated in 50 ohms'Z'. Conversion loss is stated to be -5.5DBM if LO is +4DBM or greater. I would think that the RF level alone would be adequate to cause bridge switching action but do not have specific info on its internals.

MrAl
In my haste to post schem, I omitted a 1000 pf cap inserted in series - osc. Out to 200 ohm resistor, so that would take care of the offset problem. I have done some fiddling with resistive dividing/isolation and unfortunately really could not come to any hard conclusions. But as you both have mentioned its time to connect eveything else up and give it the "acid" test, view my results from another terminal and correlate those findings with whats actually happening at the problem point. Can't get to it 'til this evening, so I'll let you both know what my results are.

User avatar
MrAl
Posts: 3862
Joined: Fri Jan 11, 2002 1:01 am
Location: NewJersey
Contact:

Post by MrAl » Mon Feb 18, 2008 3:21 pm

Hi again Robert,

OH that 1000pf cap makes a big difference he he. I was wondering
how that oscillator was going to stand putting out a dc current like
that too, into 200 ohms, which is quite low for CMOS isnt it?
I would have expected a CMOS load to be 1k or higher myself.

Anyway, the circuit with the 750 ohm resistor (same circuit really
just different part values) helps ease up the loading of the CMOS
a bit too, so you may wish to consider using something like that.
The output should be able the level you want, but maybe a little
lower because the input isnt really a sine wave 5vpp. If you have
any problems i could double check everything and set the output
level up a little higher too if you like.
LEDs vs Bulbs, LEDs are winning.

sparkle
Posts: 17
Joined: Thu Sep 20, 2007 7:43 pm
Contact:

Post by sparkle » Mon Feb 18, 2008 5:30 pm

Hmmm, some experimentation may be needed to determine whether the attenuation should be increased to isolate the filter from the oscillator, or alternatively to drive the filter somewhat hard and leave surplus power to be eaten by an isolation pad attenuator to isolate the filter from the nonlinear mixer load.

Anyway, since the conversion gain of a DBM increases to near the spec then levels off as LO drive increases, one way to approximate settings for both RF and LO drive, without using directional couplers inline to directly measure forwards and reflected power, is to measure the terminated IF output with your scope and step power with a set of attenuator pads.

Apply an estimated -10 dBm RF input, you can measure this first then attach to the RF input and assume it will not probably grow by much no matter what the RF port is doing. (For example it would have to exceed -3 dBm for an SBL-1 mixer to start to turn on the diodes without an LO, and at 0 dBm the RF drive alone has fully turned on the diodes and the RF port return loss is -19 dB.) Then apply a small LO drive and adjust upwards in small increments until IF output begins, then plot the measured IF output power. When the measured IF output remains the same within .5 dB for four consecutive 1 dB LO power increment measurements you are at the desired +7 dBm LO drive point (at the last of the four, the highest power measurement point needed and advised).

Now, assuming you have a good mixer, infer that the measured output power is the RF input level minus the spec'd conversion loss. You can now adjust the RF input level how you like as long as the output level seems to track the input level (no saturation).

Directional couplers are available from Mini-Circuits and others and remove some of the guesswork, I use some old surplus Anzac CH-132 couplers for these sort of bench measurements.

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Mon Feb 18, 2008 5:40 pm

Hi MrAl
Just popped into the computer for a couple of minutes and saw your reply. The 200 ohm series resistor has absolutely no effect on the Osc. output level- still a solid 5V p-p (it may be buffered). At this frequency though, capacitance does - 15 pf maximum . So the 200 ohm resistor gives adequate isolation for any following capacitance. I think the industry standard for CMOS specking is 50 pf which is what I see for most common logic devices.
At any rate this circuit is definately going to end up with more series resistance in its final form - possibly >400 ohms. Just got on the test bench an hour ago and have done some initial tests that show RF & LO ports are definately higher than the stated 50 ohm input 'Z'. Possibly 60 to 100 ohm. Injecting LO power definately improved the Osc. wave shape at the RF in port, but still has a long way to go. Well back to the test bench - stay tuned.

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Mon Feb 18, 2008 6:04 pm

Hello Sparkle
I guess you were posting while I was typing. As a matter of fact the mixer is a MCL SBL-1-1 and almost identical to the one you posted. The LO port is driven from a VCO (POS-200) Its level was measured at 9.7 DBM into a 50 ohm load. A 2.5DB pad was added and again checked for accuracy - perfect at 7.1 DBM output and just what I wanted. When connected to the mixer its output rose to 8.4 DBM. this cannot be changed for other circuit considerations, but it tells me that that port is higher 'Z' than 50 ohm. RF input will be the Osc. @ 100 MHzand once the level is set, it will not be changed. The LO level is well within Manu's secs (+4 - +10 DBM) so I am okay there.The RF at present is about +3 DBM and will have to be lowered to about -2DBM in its final form. Minor adjustments may be needed later for calibration.This level will also give me better fidelity in regards to RF/LO ratios but so far have not got to it yet. One amplifier stage has to be completed and the the whole package can be tested a lot easier.
At any rate, I am guessing my levels will be OK in the final form and then I can further determine the oscillator problem which is a distorted wave shape. If it were not feeding a mixer stage, I may not be too concerned, but oh those horrible byproducts it could produce scare me.

sparkle
Posts: 17
Joined: Thu Sep 20, 2007 7:43 pm
Contact:

Post by sparkle » Mon Feb 18, 2008 8:52 pm

I think your LO drive is set very well the way you did it. I think it is delivering the right voltage for an ideal load, the mixer LO port is reflecting some of it, and the sum of the reflected voltage and the incident voltage happens to yield an elevated sum voltage to be measured. But my hunch is that less real power is being absorbed into the mixer, if you had a directional coupler reflectometer and power meters I think you would see the same power inbound that you set up, but power being reflected back. I did the math on the numbers you posted, and they correspond to a VSWR on the LO port of about 1.5, this is what is spec'd in the Mini-Circuits fat catalog of spec sheets I happen to have for the SBL-1-1 LO VSWR at drive +7 dBm. So unless I did a math error or my spec is way obsolete, you are within spec and good to go.

It is really interesting to see the output on a spectrum analyzer as you crank up the RF level and it begins to approach the LO level. It is especially interesting if you have two test tones or more on the RF port and they begin to intermodulate, as in receiver as opposed to frequency shifting applications. There are always intermods, but initially they hide in the noise floor. As the input level is cranked up, suddenly they appear and grow faster than the drive is being increased, then the noise floor itself rises as intermods of intermods get formed. Even without a spectrum analyzer, you can two tone with two xtal oscillators and lay in wait for one low order intermod product with an ordinary tuned receiver S-meter, crank up the power, then back off several dB to give yourself some margin.

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Tue Feb 19, 2008 8:14 am

Agreed, once the 1 DB compression point is surpassed, IP3 rises rapidly with increasing input levels. I have been careful to keep within safe limits in the design, but I do want to keep the the mixer inputs as clean as possible. The mixer will be followed with a 10 or 12 DB pad and then into a 20DB/octave 100 Mhz lo pass filter ( pad for absorbimg reflected out of band LPF energy to reduce that level back into into the mixer). Intended IF out put to be 0.1 to 100 Mhz. But before I get back to Osc. problems, I want to get the rest of the circuit up and running to see where it stands now. Funny thing, at the onset of this project I thought the Osc. would be the least of my problems. I do wish I had A good spectrum analyser for this type of work- maybe I will add this to my wish list in the future.

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Wed Feb 20, 2008 10:43 am

After completing circuit and making further tests, I wound up with a 1000 ohm resistor feeding Pi filter and a 30 pf cap for the out put tap (feeding RF input port). RF level at mixer is now -3 DBM; LO level at mixer is +8 DBM. Subsequent testing shows that mixer is meeting Manu's specs in terms of Any combination of port isolation and conversion loss. So with that info, I think I will leave the circuit stand as it is. I want to thank all for info and support as you have been quite helpful.
MrAl , Sparkle
Would you mind if I PMed you later with more details as I don't want this Post to continue too long?

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Tue Mar 04, 2008 6:04 pm

I really hesitated to add yet another reply to this post, but when people spend their time and energy in helping, I feel they deserve some closure and here it is.
My calculations were correct. Your calculations were correct. What wasn't correct was the value of my "156 nH coil". I recently got back on this project and had the opportunity to have the coil checked in a high quality lab. It measured at 265 nH. Obviously the coil winding table I used was in error. I pulled up another table specifically for VHF & UHF coils ,rewound another coil and had it checked - 160 nH - close enough. I then installed it in the circuit and every thing fell into place. The input resistor was changed to 470 ohm and the out put was a nice clean sine wave into a 50 ohm load and at the level I wanted. Mystery solved. Thanks again Sparkle and MrAl.

User avatar
MrAl
Posts: 3862
Joined: Fri Jan 11, 2002 1:01 am
Location: NewJersey
Contact:

Post by MrAl » Wed Mar 05, 2008 12:12 am

Hi again Robert,

OH that's interesting...i wonder why the coil winding table was so
far off? Where did you find that table if i may ask?

BTW, i dont mind PM's from other people here as i assume that's what
they are there for. I talk to people a lot in PM's.
LEDs vs Bulbs, LEDs are winning.

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Post by Robert Reed » Wed Mar 05, 2008 8:11 am

Hello MrAl
The original table was pulled off the web - somewhere, I forgot the original URL. In successfully using the second one, it jogged my memory from back several years ago that the tables I was using then ( I lost track of them) actually had a correction factor for sub microhenry coils. Funny how one remembers these things after the fact and much wasted time and effort.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 39 guests