Motor speed controller issue

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
Juanu777
Posts: 4
Joined: Fri Jul 12, 2002 1:01 am
Location: Boca Raton
Contact:

Motor speed controller issue

Post by Juanu777 » Fri Jul 12, 2002 10:55 pm

Well, I'm here because contrary to my better judgement, I decided not to build the speed control circuit described in the magazine (June Issue.) I decided to test my motion control system with a commercially available DC motor speed controller. The first few rounds went OK but then my 8051 controller board went up in flames. The manufacturer of the board said that my signal isolation was the culprit and I do not know enough about the subject to argue back. I thought I was isolated since the voltage I was applying came from a different circuit powered independently. So, would anyone please tell me what is signal isolation and whether I could build the circuit to drive a 90volt 5.5A motor with stop and reverse?
Thank you in advance

russlk
Posts: 563
Joined: Thu Dec 06, 2001 1:01 am
Location: New Hampshire
Contact:

Re: Motor speed controller issue

Post by russlk » Sat Jul 13, 2002 4:22 am

To me, isolated means fully floating. If you can connect the signal circuit to 1000 volts DC without a problem, it is isolated. If the signal goes thru a transformer with a Faraday shield, then it is really isolated. More likely, in your case, there was not enuf filtering in the power supply. Voltage spikes from the motor probably exceeded the 8051 rating.<p>BTW, I have designed a motor speed control for 12 volts, 15 amps, which could be adapted by using a 600 volt IGBT.<p>[ July 13, 2002: Message edited by: Russ Kincaid ]</p>

L. Daniel Rosa
Posts: 400
Joined: Tue Dec 25, 2001 1:01 am
Location: Bellingham, WA
Contact:

Re: Motor speed controller issue

Post by L. Daniel Rosa » Sat Jul 13, 2002 12:37 pm

Signal isolation can be done in several ways. Transformers and capacitors can be used when the signal is AC. Optocouplers are good for AC or DC signals. I suspect that the two supplies were not well isolated and the uC got pulled somewhere it shouldn't go and poof! You should consider clamping the uC's outputs to it's own supply rails with two diodes, one with the anode to the controller's negative supply and the other with the cathode to the positive supply, and a resistor (highest value that will allow normal operation) downstream (signal wise) of these clamping diodes. These three components will keep the device's output from being pulled more than a few hundred millivolts outside of it's supply, and will limit the current while clamping. It's okay to use an underpower resistor so it will burn open if something goes wrong. Note that this may damage the PCB artwork if it is too close though.

Juanu777
Posts: 4
Joined: Fri Jul 12, 2002 1:01 am
Location: Boca Raton
Contact:

Re: Motor speed controller issue

Post by Juanu777 » Sat Jul 13, 2002 10:32 pm

Thanks you for your answers. I will be reviewing my design giving carefull consideration to your suggestions. Please feel free to elaborate on any ideas that might come to mind.<p>Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 27 guests