Nixie Clock Kit

Get help with your Nuts & Volts projects or Kits purchased from Nuts & Volts here.
Post Reply
User avatar
Michael Kaudze
Site Admin
Posts: 16300
Joined: Fri Nov 22, 2002 1:01 am
Location: at work
Contact:

Nixie Clock Kit

Post by Michael Kaudze » Wed Dec 26, 2007 1:48 pm

Post your comments, suggestions, or questions about the Nixie clock kit here.

Image

As seen at the 2007 Maker Faire in Austin Texas Nixie tube clocks fuse the spirit, drama and eerie beauty of cold war technology with modern works to create uncommon handcrafted timepieces. This kit includes an unstained starter box so that you can put the kit together and be able to show it off. We suggest that you use your imagination and build your own custom designed box. The possibilities are endless.

For more information on the Nixie Clock please see our October 2006 issue.

When ordering please enter your subscription account number in the Customer Note Box to take advantage of the subscriber discount. Subscriber Price $ 124.95
Intelligence is the ability to adapt to change. Stephen William Hawking.

sliderhd
Posts: 1
Joined: Tue Sep 09, 2008 5:25 pm
Contact:

Nixie clock problem

Post by sliderhd » Tue Sep 09, 2008 5:32 pm

I bought the clock a few weeks ago and finally had time to assembly it. Unfortunately something is amiss. When I power it up all tubes light up but can not tell exactly which number is actually lit. The time set switches do not appear to do anything. The numbers appear to change when I touch the crystal. I double checked all connections and found no problems. Can anyone help? Really cool kit! :???:

User avatar
dacflyer
Posts: 4266
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Nixie Clock Kit

Post by dacflyer » Mon Apr 13, 2009 5:30 pm

i'd double check the placement of your parts, make sure nothing is installed backwards..or that you did not get stuff mixed up...
good luck,,,

Dan2
Posts: 1
Joined: Sun Jan 10, 2010 8:09 pm
Contact:

Re: Nixie Clock Kit Problem

Post by Dan2 » Sun Jan 10, 2010 8:30 pm

I got this kit as a Christmas present from my in-laws.

I have soldered and trimmed all 66 nixie tube leads on the circuit board and was connecting the two boards together when I realized that I had installed the nixie tubes on the top of the board instead of the bottom.

What is the best way to desolder all of these connections in order to fix the problem? I have used desoldering braid which sucks up most of the solder from the hole, but I don't have enough wiggle room to break the leads free with 9 other pins holding it fast. Is there a way of heating all 11 pins at the same time so that I can just pull the tube out?

Once I manage to get these guys free, what's the best way to remount them from the other side, now that all of the leads are short and trimmed to length?

Sometimes reading the manual has its advantages....It was right there in Figure 13.
Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests