lm386 problem

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
danbob
Posts: 25
Joined: Sun Jan 07, 2007 8:47 pm
Contact:

lm386 problem

Post by danbob » Sat Dec 08, 2007 7:01 pm

I am building a basic lm386 amp for side tone for a keyer I just built. When I key the paddle (I am using my function generator at 700hz for testing the amp) there is a loud click in the speaker like it is getting a surge of voltage and then the tone comes through and sound good. Any ideas on how to get rid of the click?
Danbob

dyarker
Posts: 1712
Joined: Fri Aug 22, 2003 1:01 am
Location: Izmir, Turkiye; from Rochester, NY
Contact:

Post by dyarker » Sat Dec 08, 2007 8:10 pm

Are you putting the tone through the key, using DC through the key to power the amplifier, or what?

The click is probably the change in DC voltage when the key is pressed going through a coupling capacitor. More info needed to say.

The best info would be a schematic of whole circuit.

Cheers,
Dale Y

User avatar
MrAl
Posts: 3862
Joined: Fri Jan 11, 2002 1:01 am
Location: NewJersey
Contact:

Post by MrAl » Sun Dec 09, 2007 3:26 am

Hi there,

I would have to agree, that the click is probably from the change
in dc level when keyed. When the dc level changes it creates a
wavefront that has a lot of harmonics in it, some of which get to
the output and make the noise.
The thing is, this might be difficult to get rid of. A sine wave that
is switched to an output at a random time will also sometimes
produce an unwanted sound for the same reason.
As already mentioned by dyarker, it would be good if we could see
your schematic so we can provide more accurate solutions.
LEDs vs Bulbs, LEDs are winning.

danbob
Posts: 25
Joined: Sun Jan 07, 2007 8:47 pm
Contact:

lm386

Post by danbob » Sun Dec 09, 2007 5:12 pm

this is the circuit that I am using. I changed the signal from sine wave to square wave and it got rid of the click ( the keyer buts out a square wave). also I found that I had to bypass the +voltage to ground or the lm386 went in to oscillation. I tried removing the resistor and cap between ground and pin 5 (a filter?) and it did not change the sound any but on the scope it looked like the bottom half of the sine or square wave was modulated. I guess the click may have been caused by the function generator.
Image

dyarker
Posts: 1712
Joined: Fri Aug 22, 2003 1:01 am
Location: Izmir, Turkiye; from Rochester, NY
Contact:

Post by dyarker » Sun Dec 09, 2007 7:03 pm

Where is the relative to this? I'll assume between function generator and input.

When function generator in sine mode, is the tone output riding a DC level? And in square wave mode, the output switches between 0 volts and some voltage? That would explain click with sine and no click with square.

If you're happy listening to square wave, then job done. If you'd rather use sine waves, then try a series capacitor (maybe like 0.1uF) on output of function generator with a resistor (like 47K) to common before the key. The cap will block the DC. The resistor maintains the DC charge on the cap when the key is up. (If the function generator already has a blocking cap inside, then only the resistor across the output is needed.)

Cheers,
Dale Y

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests