adc0804

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
catcher
Posts: 8
Joined: Thu Oct 03, 2002 1:01 am
Contact:

adc0804

Post by catcher » Sat Sep 20, 2003 7:44 pm

I need help understanding the output of an adc0804. I hooked up the test circuit on page 24 of the data sheet. My Vi+ was 750mV coming from a lm34 temp. sensor. My Vref was 2.56V. My Vi- was tied to ground. The led output was from MSB to LSB 11011011. How do I read this binary number. The data sheet mentioned this to be a hex number, but that does not make sense to me? BC in hex? I also did not understand the outputs being tied to 5v. I thought the outputs would either put out 0 or 5v on each pin to make a binary code that would match the Vin+ value. I would appreciate it if someone could explain this to me. Thanks

Ron H
Posts: 360
Joined: Tue Dec 18, 2001 1:01 am
Location: Boise, ID
Contact:

Re: adc0804

Post by Ron H » Sat Sep 20, 2003 8:22 pm

First of all, a lit LED is a logic zero. You can see this from the schematic. So your output code is really 0010 0100, which is 24H. From the table, the code indicates that the input voltage is 0.72v. Your output code should have been 24H or 25H (0.74v or 0.76v). This part is supposed to be accurate +/-1 LSB, so, considering measurement errors, it's probably OK.<p>If you read the datasheet carefully, you'll see that 2.56v on pin 9 (I'm assuming that's what you have) means your reference voltage is effectively 5.12v (see p.21). 750 mv/5.12v=0.1465. Multiplying this by 2^8, the output code should be 37Dec or 38Dec, which is 25H or 26H.

catcher
Posts: 8
Joined: Thu Oct 03, 2002 1:01 am
Contact:

Re: adc0804

Post by catcher » Sun Sep 21, 2003 3:00 am

Thanks Ron. I was getting the right output, just reading the leds wrong. Is it possible to get an a/d chip to read the third digit of the input to give me a more accurate answer?

Ron H
Posts: 360
Joined: Tue Dec 18, 2001 1:01 am
Location: Boise, ID
Contact:

Re: adc0804

Post by Ron H » Sun Sep 21, 2003 7:15 am

Well, that depends on what the range of your input voltage is. Do you really need a range of 0 to 5.12v, as you have with the current design? Right now, you have 20mv resolution (5.12/2^8=0.02). To get 1mv resolution with the same input range, you'll need a 13 bit A/D. To get 1mv of resolution with an 8 bit A/D, you can only have a span of 256mv (see how that works?). The data sheet shows how to change the span and offset. You may need more bits, but you may NOT need 13 bits. If you can't figure it out on your own, be specific about what your requirements are and I'll try to help.

catcher
Posts: 8
Joined: Thu Oct 03, 2002 1:01 am
Contact:

Re: adc0804

Post by catcher » Mon Sep 22, 2003 11:04 am

Ron, You have been a great help. After playing with the circuit, I set up .75volts on my ref. (pin 9). After working through the math, this gave me .0058 for 8 bit resolution. It appears to work within .5 of a degree tolerance. Now, I am going to feed this to a pic and make a LCD readout of it. Thanks again.

Ron H
Posts: 360
Joined: Tue Dec 18, 2001 1:01 am
Location: Boise, ID
Contact:

Re: adc0804

Post by Ron H » Mon Sep 22, 2003 12:28 pm

Thanks for the feedback. Frequently, we never hear if our suggestions were helpful or not. I'm glad you got your A/D working.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 8 guests