Linear power supply problems

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
User avatar
dacflyer
Posts: 4533
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Linear power supply problems

Post by dacflyer » Thu Jul 02, 2020 12:29 pm

I have a old pyramid 20A power supply that is dropping out at 8A or so.
if i turn it off then back on, it will work for a bit then drop out again,,
I think something is tripping the over current circuit.
if i remove the load, it rests itself.
It's a simple circuit.
kind of like this..
Pyramid_PHASE_III_by_Tenna_PS-20_Power_Supply_schematic.jpg
really wanna build a power supply that is adjustable current and voltage.
something up to bout 50v @ 20A.
anyone ever saw something like that ?
could the schematic i posted be modified to work ?

User avatar
haklesup
Posts: 3023
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Linear power supply problems

Post by haklesup » Thu Jul 02, 2020 1:45 pm

increasing current should just be a matter of adding more output transistors or substituting higher power ones. Increasing voltage is not usually so straightforward but the LM723 should operate up to 40V, you may need to tweak some resistor values though. Study the datasheet and the many examples online to find the best solution.

Most electronics today run at 3.3, 5, 9, 12, 24V only some aerospace and military modules run at 48V. a Variable 5V supply seems like it might not be used

50V, 20A is a 1kW power supply, the linear transformer to deliver that power will be heavy and possibly expensive if you insist on linear. In any case, the simplest thing you can do is get a Variac and install a full wave bridge rectifier and filter and you should get very wide range with lots of power. That primary can then be further conditioned downstream with regulation, limit and protection components or modules.

for 20A, you are going to need a big heatsink for the transistors too

User avatar
jwax
Posts: 2195
Joined: Mon Feb 09, 2004 1:01 am
Location: NY
Contact:

Re: Linear power supply problems

Post by jwax » Tue Jul 07, 2020 5:03 am

Missing wire from the top of the bridge?

Dropping out at 8 amps may be thermal- do you have an infrared viewer to locate the hotspot? Or, run a fan over the heatsink and see if it behaves that way?

User avatar
dacflyer
Posts: 4533
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Linear power supply problems

Post by dacflyer » Tue Jul 07, 2020 12:44 pm

This power Pyramid supply is supposed to operate up to 20A, there is no thermo problems, nothing even gets hot, it's got 4 2N3055 transistors.
and the driver is also a 2N3055.

The other power supply is just something that would be nice to have.
I see all these LAB quality power supplies, and they are barely anything for current.
I do have some really hefty transformers laying around.
If that LM723 IC can control up to 40V, I might be fine with that. if it can be variable voltage, and current.

User avatar
haklesup
Posts: 3023
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Linear power supply problems

Post by haklesup » Tue Jul 14, 2020 4:15 pm

I wouldn't expect much heat until It is operated at max load for a little while. The VCE at full load of the transistors x the current in each will determine how many watts each transistor must shed. If the heatsink is more than needed, it will not seem to get very warm. regardless, the transformer still must provide all that current so it will be large and have heavy gauge wire in the turns. this make high current linear supplies economically a poor choice.

More than likely if you modify for 40V range and add a few more transistors in parallel then you should be pretty close. This probably requires modification of a number of the passive component values as well due to the V range changes.

User avatar
dacflyer
Posts: 4533
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Linear power supply problems

Post by dacflyer » Thu Jul 16, 2020 5:00 am

well, i will be going all thru this old 20 amp unit,, and figure it out.. I didn't know if there was some sort of common failure issue.
If less then 8A it'll work fine.

User avatar
haklesup
Posts: 3023
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Linear power supply problems

Post by haklesup » Thu Jul 16, 2020 1:30 pm

the chip should be very low cost and the passives should be able to check with a DMM. Maybe just replace the chip rather than try to prove its bad first might be quicker to eliminate that possibility. I doubt its the transistors but maybe.

Draw a graph of load current vs output voltage, it may not show a breakdown at 8A, it just might run out of power if the transformer is undersized or if the bridge rectifier has one leg out. if it is underpowered it should trail off more or less linearly but if its failed, it may simply cut out or drop at certain trigger level and result in an otherwise piecemeal graph

User avatar
dacflyer
Posts: 4533
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Linear power supply problems

Post by dacflyer » Sun Jul 19, 2020 2:54 pm

I'll try that sometime soon..
the transformer is OEM, hell it's all OEM.
so the transformer is unlikely underpowered.
but i'll let ya know what i find.

gerty
Posts: 303
Joined: Mon Dec 06, 2004 1:01 am
Location: Tennessee
Contact:

Re: Linear power supply problems

Post by gerty » Mon Jul 20, 2020 1:30 am

I'd test the 3055's , you may have one or two of them failing to turn on. That would cause the others to flake out..

User avatar
dacflyer
Posts: 4533
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Linear power supply problems

Post by dacflyer » Mon Jul 20, 2020 4:38 am

will do..

User avatar
haklesup
Posts: 3023
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Linear power supply problems

Post by haklesup » Tue Jul 21, 2020 10:27 am

I agree the OEM transformer should do its original job but it could have shorted secondary windings which would change its output characteristics. A failure of the full wave bridge such that it acted more like a half wave would allow it to seem to work but at reduced power and greater noise.

But looking closer and focusing on Cx, That's probably a bank of large electrolytic caps. These are notorious for going bad when they get old and can do a range of things to the output like adding ripple and reduced power. In equipment I sell, we recommend changing all caps in the PS at 10 years regardless. Bug caps can cost a lot but I'd bet the ESR is way out of spec by now and may even be electrically leaky. If they get warm during operation with no load, they are bad.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests