Forum Update! Secure!

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Sean Lemieux
Posts: 15
Joined: Mon Jan 07, 2013 2:33 pm
Contact:

Forum Update! Secure!

Post by Sean Lemieux » Fri Sep 21, 2018 7:48 am

Hey everyone,

I saw a few comments about the forum not being secure. I have taken care of the problem and as far as I can see, all pages should be reading secure. Please take a look and report any anomalies to me.

Thank you in advance for your help!

Sean Lemieux

User avatar
Externet
Posts: 1801
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Forum Update! Secure!

Post by Externet » Fri Sep 21, 2018 8:43 am

Some members want to insert images; Testing insertion of picture...
In full editor mode; copy and paste, not dragging :
/home/externet/Desktop/Triangles.jpg

Edited : (Did not work)

Dragging and dropping, from desktop to this message box :

Second edit: (Did not work) and did not preview.

Trying "the add files" method:

Third edit : (Did not work) and did not preview.

So far for attachments, :sad:
- Abolish the deciBel ! -

Sean Lemieux
Posts: 15
Joined: Mon Jan 07, 2013 2:33 pm
Contact:

Re: Forum Update! Secure!

Post by Sean Lemieux » Fri Sep 21, 2018 3:21 pm

Externet: yes, we are aware of this problem. We are in the process of fixing all this so bare with us, hopefully the issue with uploading photos will be fixed soon.

-Sean

dyarker
Posts: 1670
Joined: Fri Aug 22, 2003 1:01 am
Location: (somewhere), Afghanistan; from Rochester, NY
Contact:

Re: Forum Update! Secure!

Post by dyarker » Fri Sep 21, 2018 7:43 pm

The image button above the text to post box is for URL to image on a server, not the directory and file name on your PC. And it works perfectly.

To upload to this site's server you need the Attachments tab below the text box. It is not accepting images (.bmp, .jpg, .png) yet.

As they lease server space and forum software. it is not as simple as someone at T & L making a decision. They may have to get another company to make software changes. You've got Sean's attention, he'll tell us when it is ready to try.

Cheers,
Dale Y

User avatar
CeaSaR
Posts: 1631
Joined: Sat Nov 08, 2003 1:01 am
Location: Phoenixville, PA USA
Contact:

Re: Forum Update! Secure!

Post by CeaSaR » Sat Sep 22, 2018 5:51 am

Like Dale said^^, the picture situation works correctly with a third party host.

I can give 2 analogies that describe our situation with this board.
1. Standard texting vs multimedia texting. Standard text allows just text and certain built in emojis. It also allows page links.
Multimedia text allows all of the above plus the attachment and display of pictures, movies, sound, and whatever else your version allows.
2. On Facebook, when you share something from another website, a link is inserted and normally you get a preview of that link. For example, you find a video on how to build the world's only over-unity generator in hopes of putting the big energy companies out of business (lol), you either click the share button on YouTube or copy the provided URL and paste/allow the sharer program to put it in a post on your page. A link is inserted and a preview is generated. When you click the preview, a new window is launched to view this greatness.

The other option you have is to directly insert the photo/video/etc. directly into a post. In this case you would click the insert button (attachment button in our case), select the file and wait for it to be uploaded to the site. It then becomes a part of the post (sort of, they are actually stored in media directories within FB, which is similar to the way most Web pages display media).

This board works like the first instances described above, where the format is more text oriented, NOT multimedia oriented. That being said, using the 3rd party solutions mimics multimedia, albeit with more work on our part. In a world where instant convenience is more or less demanded, I can see where this is viewed as antiquated. Of course, I remember writing websites in NotePad, so my perspective is different. :D

CeaSaR
Hey, what do I know?

User avatar
Externet
Posts: 1801
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Forum Update! Secure!

Post by Externet » Sat Sep 22, 2018 6:20 am

Thanks for the efforts.

To refer about the past, searched a guessy term : "2014" ; and showed among results :

----> https://forum.nutsvolts.com/viewtopic.p ... hilit=2014

Which makes me think the forum software is/was capable of image attachments and such was disabled. Perhaps it would be good to dig deeper into the features and settings. I remember being able to insert images with no hurdles years ago.

Edited: After entering 'Submit' for the text above, refused to post, requesting to login (again); and remembering this particular hurdle, instead of obeying, going back and copying the text, avoids losing it in limbo and having to retype. Redacting in a 'note pad' does not consume the time limit taken to type directly an elaborated response on the text box.

Seems in 2015 this test at post #13 (not numbered!) worked :

----> https://forum.nutsvolts.com/viewtopic.p ... cce0b02a30

But may have been from an external URL...
- Abolish the deciBel ! -

User avatar
CeaSaR
Posts: 1631
Joined: Sat Nov 08, 2003 1:01 am
Location: Phoenixville, PA USA
Contact:

Re: Forum Update! Secure!

Post by CeaSaR » Sat Sep 22, 2018 7:02 am

Yes, the phpBB software has the ability to directly upload photos. Details are on their website. However, this doesn't mean that the version used here is the full featured one (not even sure if that's possible) or if the server used to run the board has that enabled or even has permissions available. All that is up to N&V as they are paying for us to be able to use this forum.

As to your other problem (no posting, login...), I personally have rarely, if ever had those problems. My post above was done on my phone, which "goes to sleep" a lot faster than my desktop or other devices, and I had no issues whatsoever. As a matter of recall, I don't ever remember having had a problem with the login situation. The "POOF! post", yes it has happened in the past. Usually due to the auto-refresh of the browser. That's why I do a "select all" and "copy" often when doing long posts.

CeaSaR
Hey, what do I know?

User avatar
evahle
Posts: 186
Joined: Mon Aug 13, 2007 3:48 am
Contact:

Re: Forum Update! Secure!

Post by evahle » Sun Sep 23, 2018 8:33 pm

I noticed the other day the forum has stopped sending notifications to my email when someone posts in the threads that I've been watching. Has something changed here? I didn't see anything wrong in my settings that I've noticed.

Sean Lemieux
Posts: 15
Joined: Mon Jan 07, 2013 2:33 pm
Contact:

Re: Forum Update! Secure!

Post by Sean Lemieux » Tue Sep 25, 2018 11:25 am

Externet: I experienced having to re-login/authenticate on the Administrator end of the forum but haven't heard any problems on the user end of the forum. The problem on the back end was a cookie setting which has been resolved as of today so if you get any re-authentication problems from hear forward, please let me know so I can look into them and address it!

Evahle: Nothing has been changed in any email settings so I'm not sure why the notifications are not being pushed through. I'll set some threads to inform me of activity and see if I can replicate the problem.

Also as an update, I'm working with a developer on this image upload problem so I will keep everyone updated as things progress. Thank you for your patience!

User avatar
evahle
Posts: 186
Joined: Mon Aug 13, 2007 3:48 am
Contact:

Re: Forum Update! Secure!

Post by evahle » Tue Sep 25, 2018 12:00 pm

I found my problem with the notifications. I'm glad you're working on the images problem. Thanks!

Sean Lemieux
Posts: 15
Joined: Mon Jan 07, 2013 2:33 pm
Contact:

Re: Forum Update! Secure!

Post by Sean Lemieux » Mon Oct 15, 2018 12:32 am

I believe direct uploading of attachments is now fixed. Please try posting your pictures and report any malfunctions to me.

User avatar
evahle
Posts: 186
Joined: Mon Aug 13, 2007 3:48 am
Contact:

Re: Forum Update! Secure!

Post by evahle » Tue Oct 16, 2018 5:46 pm

Working for me so far Sean. Thanks!!

robertwadera
Posts: 4
Joined: Thu Nov 15, 2018 5:47 pm
Contact:

Re: Forum Update! Secure!

Post by robertwadera » Thu Nov 15, 2018 5:52 pm

Thanks. I have a similar issue. I will try your solution and see if it works slope game

User avatar
dacflyer
Posts: 4292
Joined: Fri Feb 08, 2002 1:01 am
Location: USA / North Carolina / Fayetteville
Contact:

Re: Forum Update! Secure!

Post by dacflyer » Fri Nov 16, 2018 10:57 am

seems there's a lot of spam coming in suddenly..
not so secure..

dyarker
Posts: 1670
Joined: Fri Aug 22, 2003 1:01 am
Location: (somewhere), Afghanistan; from Rochester, NY
Contact:

Re: Forum Update! Secure!

Post by dyarker » Fri Nov 16, 2018 12:08 pm

((even the spammers were encrypted while created user accounts :grin: , (different protection called for)))
Dale Y

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 11 guests