Velleman kit

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
User avatar
Lenp
Posts: 1454
Joined: Thu Oct 26, 2006 8:11 pm
Location: Maryland
Contact:

Velleman kit

Post by Lenp » Sun Aug 03, 2014 8:38 pm

I have assembled more than my share orf kits stating way back with Knight Kit all the way to the popular Velleman line. Recently my granddaughter, who's a bit accomplished at soldering, worked hours on a MK170 Sound Star.
It is a sound activated star with 60 LED's plus the supporting parts.
The parts look like quality and the design is clever but the circuit board is trash.
The foil is so thin that the pads, which are slightly wider than the lead, lift and disconnect in epidemic proportions!
I took over some of the assembly for her and had no better luck. I have designed, etched and assembled countless boards and quality temp controlled irons and solder are at hand. At the slightest touch the pads broke loose from the trace. To make it worse there is a black solder resist coating over the foil so it is pretty tough to see the traces under the coating. You have to scrape the coating to explore where the trace is! I fixed a dozen or more bad pads but success is really dim right now. If the foil layer was thicker and the pads larger there would not be a problem. If I can't resurrect his gadget the salvage value is zero! To have success with this board I would recommend installng the LED's then epoxying them in place before soldering, but that's NONSENSE!
Len
Len

“To invent, you need a good imagination and a big pile of junk.” (T. Edison)
"I must be on the way to success since I already have the junk". (Me)

User avatar
jwax
Posts: 2201
Joined: Mon Feb 09, 2004 1:01 am
Location: NY
Contact:

Re: Velleman kit

Post by jwax » Wed Aug 06, 2014 4:00 am

I've usually had success with Velleman boards/kits. Sounds like a POS board got through their QC.
Have you told them of your troubles? They ought to replace the board, at least!

User avatar
Lenp
Posts: 1454
Joined: Thu Oct 26, 2006 8:11 pm
Location: Maryland
Contact:

Re: Velleman kit

Post by Lenp » Wed Aug 06, 2014 4:23 am

What! A new board? Remove a zillion parts and start over! That's not in the agenda..
Len

“To invent, you need a good imagination and a big pile of junk.” (T. Edison)
"I must be on the way to success since I already have the junk". (Me)

Dean Huster
Posts: 1263
Joined: Wed Dec 05, 2001 1:01 am
Location: Harviell, MO (Poplar Bluff area)
Contact:

Re: Velleman kit

Post by Dean Huster » Wed Aug 06, 2014 6:28 am

You're over-reacting, Len. Maybe half a zillion at most.

Forgive me if it seems like I'm "preaching" to the choir, but I have to throw this out to you anyway, just to make sure you have the bases covered. Most pads lift because of solder temp that's too high or worse yet, too much time spend soldering an individual joint. It's a bitter-sweet situation: lowering the temperature may increase the time spent on the joint; to reduce joint time, you have to raise the temperature. Danged if you do, danged if you don't. It's finding the perfect combination.

Are you using a nice 63/37 eutectic alloy with a low melting point for the solder or some of the new lead-free crap that requires hotter temps? A run across the board with a Scotchbrite pad to clean things up quickly will help. Adding a bit of liquid flux to each pad before soldering may help. Keeping the tip of your iron shiny as a mirror with tinning is a must. A tip that matches the width of the pad is a plus for best heat transfer. I'm outta ammo right now.
Dean Huster, Electronics Curmudgeon
Contributing Editor emeritus, "Q & A", of the former "Poptronics" magazine (formerly "Popular Electronics" and "Electronics Now" magazines).

R.I.P.

User avatar
Lenp
Posts: 1454
Joined: Thu Oct 26, 2006 8:11 pm
Location: Maryland
Contact:

Re: Velleman kit

Post by Lenp » Thu Aug 07, 2014 5:17 pm

No Dean, no preaching to the choir. It's always good to review practices and maybe another reader will learn a few tricks.
One real issue with that board is the LED's are not close to the board. They stand away because of the stop bumps on their leads and any movement leverages the pad and it disconnects. This board also uses other through hole component, that are inserted from the solder side and soldered like a surface mount. No problem with any of these, just the LED's!
The LED's are in series strings, finding the open is easy once the trace is excavated from under the coating. If I could dissolve it all the fix would be a snap. Yes Velleman does have a schematic on-line but the LED's are not identified on the board for anything other than color and polarity!
This will go in the 'free time' box!
Len
Len

“To invent, you need a good imagination and a big pile of junk.” (T. Edison)
"I must be on the way to success since I already have the junk". (Me)

User avatar
haklesup
Posts: 3040
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Velleman kit

Post by haklesup » Mon Aug 11, 2014 12:11 pm

Sounds like you could find the opens with a DMM as well then "blue wire" repair the open traces. The manufacturer should replace the entire kit in this case, they may or may not want to old one back. They may try to say it was due to assembly techniques but if you persist they will probably do you right if they are reputable. There are many reasons a PCB could be low quality and fail like this. It could be anything from the choice of soldermask to the adhesion of the copper to the PCB.

Similar to Dean's advice, do not use lead free and I would add use additional flux. Flux can work miracles on hard to solder connections, it almost always reduces the amount of heat you need to put in for a good reflow. Most solder has flux core but I am advocating paste or liquid flux, I prefer water clean-up types so I can wash boards in the sink with dish soap (actually liquinox but I don't expect you have some of that).

Post Reply

Who is online

Users browsing this forum: No registered users and 42 guests