Pissed off with service manual...

This is the place for any magazine-related discussions that don't fit in any of the column discussion boards below.
Post Reply
User avatar
Externet
Posts: 1831
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Pissed off with service manual...

Post by Externet » Tue Oct 18, 2011 4:02 pm

Trying to repair a friend's huge expensive TV; its service manual "full version" does not have schematic diagrams :

----> http://www.scribd.com/doc/49812636/Mits ... anual-full

What the @*&^$!&% is that? :x
All the studying, skills and experience in troubleshooting to pinpoint a bad chinese $0.15 part to put back to work a $3000 TV are not worth sh*t any more ?
So it broke; dump it ?
Or buy the whole $ubassembly and troubleshoot nothing ?
Servicing aimed to be performed by any pseudo-technician apprentices who never learned soldering ?

:x Miguel
- Abolish the deciBel ! -

User avatar
Janitor Tzap
Posts: 1426
Joined: Sat Aug 12, 2006 5:17 pm
Contact:

Re: Pissed off with service manual...

Post by Janitor Tzap » Tue Oct 18, 2011 6:16 pm

It's called planned obsolescence. :(
Most every new piece of electronics that has been made in the last 10 or so years.
Isn't supposed be repaired, just replaced.
That's the reason why many TV/Audio Repair shops have gone under. :(

But I will agree with you about this Repair Manual.
It has a listing of parts, simple block diagrams, and wire inter-connect diagrams.
But no actual schematic's of the boards.
{That's just plain stupid} :x

I also tried to ZOOM-IN on the wire inter-connect diagrams on the last page.
No matter how I tried, I couldn't make out the small writing. :sad:

What is the problem with the set?
Dead?
Projection bulb burned out?
Intermittent connections?
What do the Stasis leds show?

Thus,
With this knowledge.
Then perhaps some of us here will be able to help you.


Signed: Janitor Tzap

User avatar
Externet
Posts: 1831
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Pissed off with service manual...

Post by Externet » Wed Oct 19, 2011 7:48 am

Hi Tzap.

Thanks. The unit is very dead. From a blocky sketch on page 46, I reversed engineered the power supply and make a partial schematic; learned something.
Will check the data sheet for the standby switcher IC STR W6735 to figure out its operation requierements. Voltages are about a tenth of what they have to be; and that is with no load. Capacitors, rectifiers and +170V are fine, nothing is burned, bulged, warm... Will check optocouplers and all I can suspect of.

Miguel
- Abolish the deciBel ! -

User avatar
VernGraner
Posts: 223
Joined: Sun Mar 02, 2003 1:01 am
Location: Austin Texas
Contact:

Re: Pissed off with service manual...

Post by VernGraner » Wed Oct 19, 2011 9:38 am

Externet wrote:Trying to repair a friend's huge expensive TV; its service manual "full version" does not have schematic diagrams :

----> http://www.scribd.com/doc/49812636/Mits ... anual-full
Don't know if this will help, but it seems Sams has a schemaitc.. no telling if its the same as the one above as there is no preview image:

Sams WD62525 Manual

Vern
--
Vern Graner

User avatar
Janitor Tzap
Posts: 1426
Joined: Sat Aug 12, 2006 5:17 pm
Contact:

Re: Pissed off with service manual...

Post by Janitor Tzap » Wed Oct 19, 2011 11:04 am

Externet wrote:Hi Tzap.

Thanks. The unit is very dead. From a blocky sketch on page 46, I reversed engineered the power supply and make a partial schematic; learned something.
Will check the data sheet for the standby switcher IC STR W6735 to figure out its operation requierements. Voltages are about a tenth of what they have to be; and that is with no load. Capacitors, rectifiers and +170V are fine, nothing is burned, bulged, warm... Will check optocouplers and all I can suspect of.

Miguel
Hmmm.........
You have no lights at all?

If this true, then I'd say your looking at the right area.

But just to be sure.....
Look at the LED truth tables on pages 20 - 23.

As for the Switcher Regulator.
Here's the datasheet-pdf.
http://www.alldatasheet.com/datasheet-p ... W6735.html


Good luck!


Signed: Janitor Tzap

Bear
Posts: 52
Joined: Sun Jun 27, 2004 1:01 am
Location: California, SF Bayarea
Contact:

Re: Pissed off with service manual...

Post by Bear » Wed Oct 19, 2011 11:28 am

Miguel... Maybe I am missing something here but, my viewing of the service manual does not have any pages #43, 44, 45 or 46. If I go to pages 71, 72 & 73 it shows schematics for the main pwr supply and other pwr supplies. If you want I can download the copy of the manual & email to you. Please advise if I am missing something or if you want me to email copy to you.

Edit of post. Yeah I did miss something. I was looking at wrong model. However some of the other models may have useful schematics. I do not know the difference between the models ending in #5 or ending in #7.

Take Care

Dennis

User avatar
Externet
Posts: 1831
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Pissed off with service manual...

Post by Externet » Wed Oct 19, 2011 3:14 pm

OK, gentlemen...
Vern... Am at a point I cannot expect that Sam's link to have more pages than the "full" version; buying it to find the sad surprise it is the same I already have...

Tzap... no lights, no nothing. Dead. Been futzing with my reverse engineered schematic and the data sheet; but HATE guessing; I usually pinpoint the problem with certainty before ordering a part. This time I may go for an educated guess and swap that switcher, as measured all resistors and everything else shows good. :sad:
+15 V is +4 V; -15V is -4 V; +12 is +2V; +6 Vis 1.7V... all others are well under specs low. No 3.3V; no 5V.

Dennis... Interesting; can you please supply the link to a similar unit you found the schematics in the service manual ? It would help !

Thanks
Miguel
- Abolish the deciBel ! -

User avatar
haklesup
Posts: 2945
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Pissed off with service manual...

Post by haklesup » Wed Oct 19, 2011 5:50 pm

Are you measuring those voltages with no load?

If it has a load (still plugged into other circuits) then maybe you are only seeing current limiting on the supplies

If you have unplugged the load, then you probably have proven the power supply is dead. I say probably because some (usually older) switchers needed a minimum load to regulate. Measuring those with no load would be invalid.

I didn't see a PS test procedure when I scanned through the link. I also note that when they say switched power supply, they do not mean a switching power supply necessarily, only that it gets switched on and off when the TV is powered on. It looks like if the 12VS supply on the standby section is bad, nothing on the switched part will activate. Are you getting realistic readings at the fuses F9A02 thru F9A05

Given your symptoms and the observation that for other types of displays its usually the power supply or some other HV source that goes (like a CFL backlight). I agree, you have a good first guess

I also agree, it was pretty lame to make such a service manual and leave out the most useful part. MOst user servicable probelms are mainly alignment issues, the manual spends a good amount of time on that subject.

Dispite how expensive thet TV was in (when 2004, 2005), you friend can replace it now for a fraction of the cost with an LCD (unless he gets carried away and wants 60" and 3D with spare goggles)

User avatar
Externet
Posts: 1831
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Pissed off with service manual...

Post by Externet » Thu Oct 20, 2011 9:30 am

Hi haklesup.
Yes, the board standing alone out of the unit; on its standby PS section test points. Nothing has realistic readings.
Correct, the 'switched' section of this PS comes on only after the unit is turned on.

The owner and I just want to put this monster back to work instead of landfilling.

Miguel
- Abolish the deciBel ! -

Bear
Posts: 52
Joined: Sun Jun 27, 2004 1:01 am
Location: California, SF Bayarea
Contact:

Re: Pissed off with service manual...

Post by Bear » Thu Oct 20, 2011 2:21 pm

Miguel...Here is the link. Sorry but I don't know how to make it a clickable(sic?) link. I'm sure just copying it and pasting it into your web browser will work. Hope the info works for you.

http://www.scribd.com/doc/60494569/V29- ... ice-Manual

Take care

Dennis

User avatar
haklesup
Posts: 2945
Joined: Thu Aug 01, 2002 1:01 am
Location: San Jose CA
Contact:

Re: Pissed off with service manual...

Post by haklesup » Thu Oct 20, 2011 5:50 pm

you may want to consider loading the outputs of the supply with a 500 ohm resistor (approx) just so you are sure its not the kind of supply that has a min load to regulate.

User avatar
Externet
Posts: 1831
Joined: Fri Feb 01, 2002 1:01 am
Location: Mideast USA
Contact:

Re: Pissed off with service manual...

Post by Externet » Fri Oct 21, 2011 10:05 am

Hi haklesup.
You are confusing me... :smile: the PS board connected to the TV (that is a load) has the same bad behavior as with no load, disconnected.
- Abolish the deciBel ! -

Robert Reed
Posts: 2276
Joined: Wed Nov 24, 2004 1:01 am
Location: ASHTABULA,OHIO
Contact:

Re: Pissed off with service manual...

Post by Robert Reed » Fri Oct 21, 2011 6:08 pm

I think what he means is to isolate the power supply and put a small load on it (the 500 ohm mentioned). The TV as a load may be defective and loading down PS voltages. Disconnected and standing unloaded may cause the same symptoms in some switchers.

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests