N&V Balance Bot compile problem

Interested in Robotics? Here's the place to be.
Post Reply
Ronbot
Posts: 5
Joined: Fri Nov 24, 2006 1:34 am
Contact:

N&V Balance Bot compile problem

Post by Ronbot » Fri Jun 26, 2009 6:38 am

Hello,
I recently started building the Balance Bot from the N&V december 2006 issue. I used the latest version of WinAVR to compile the software with the supplied make file. The compilation seems to go well at first be stops with an "error 1" message, just as it is busy with ".elf" files. I see lots of .o file that seem okay. It means that I am stuck since I am a newby to AVR (i am a PIC man myself)

Anybody out there who has succesfully compiled the software from the N&V site or has run into the same problem ?

Any help appreciated.

Ron

Ronbot
Posts: 5
Joined: Fri Nov 24, 2006 1:34 am
Contact:

Re: N&V Balance Bot compile problem

Post by Ronbot » Mon Aug 03, 2009 4:13 am

????

ericvb
Posts: 2
Joined: Sun Feb 14, 2010 6:25 pm
Contact:

Re: N&V Balance Bot compile problem

Post by ericvb » Sun Feb 14, 2010 7:06 pm

I'm trying to compile the Balancing Bot source code.
Can you help me with this ?

Thanks
Eric V. Barreto.

Ronbot
Posts: 5
Joined: Fri Nov 24, 2006 1:34 am
Contact:

Re: N&V Balance Bot compile problem

Post by Ronbot » Sun Feb 14, 2010 11:57 pm

Hi Eric,
Because I am new with the AVR toolset I have been unable to compile the code using the AVR. I decided to go with a PIC microcontroler (18F series) using PCH. I had to make changes to some part of the code and it now compiles. I still need to do some work with the actual build and then experiment with the settings. If interested I can post the PCH C code

Ron

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests