It is currently Sun Jan 21, 2018 9:53 pm

All times are UTC - 8 hours




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: HELP! This audio amp is getting the better of me...
PostPosted: Thu Sep 26, 2013 11:53 pm 
User avatar

Joined: Sat Jan 11, 2003 1:01 am
Posts: 200
Location: Chattanooga, TN
I have an audio program out amplifier from a seventies-era radio broadcast mixer. Somehow, I've shorted both of them to failure. Dead. I desperately need to get them repaired to enable the needed functions of my console, but I've studied, tested, poked, prodded, studied more, tested more, etc. and I'm getting nowhere in a lot of hours.
It seems to be a pretty simple module, but danged if I can get a grip on it (of course I have no real knowledge of electronics, but it's never stopped me before..haha)

Can someone explain to me how this works? I have the schematic and have studied it constantly, but...
I've also thought about the possibility of replacing the unit with something more modern and small, but again, things
don't line up with my way of thinking--the console connectors have three red wires that feed 45vdc, and I believe 3 black wires with no voltage, and then a white wire with no voltage. I know that a good working module installed enables Monitor and Program functions to work through a volume control into speakers. In other words, can't seem to figure out how to connect up a newer device that would still let the functions of the console work...make sense?
If anyone interested, there is a Manual on the net: Harris Stereo 80 console. I have a copy of it...
Any help at all would be tremendously appreciated...

Tim


Offline
 Profile Send private message  
 
 Post subject: Re: HELP! This audio amp is getting the better of me...
PostPosted: Sat Sep 28, 2013 7:33 am 

Joined: Wed Apr 10, 2013 5:03 am
Posts: 12
You say it's dead, shorted both of them to failure. Have you checked the power supply voltages? Do you have two of these that you can compare/scavenge parts?

You gotta love the old manuals. That schematic is the busiest I've seen in a long time but it give you tons of info that you can't find now days. You say three reds and three blacks with 45 volts on the reds. Sounds to me like you've got lots of 45 volts which would rule out the power supply. I can't see where that is on the schematic though.

A little more info on what's dead and what's working may help.


Offline
 Profile Send private message  
 
 Post subject: Re: HELP! This audio amp is getting the better of me...
PostPosted: Sun Sep 29, 2013 12:44 am 
User avatar

Joined: Sat Jan 11, 2003 1:01 am
Posts: 200
Location: Chattanooga, TN
Hmmm...not sure what else I can tell you...let's see...
Yesterday, I dug a little deeper into the schematic trying to understand just a tad of it, and I believe I have found two or three transistors showing bad (I did pull them from the circuit and tested with my DMM diode setting)...2Q7 and I believe 2Q4 had bad readings...earlier,
I had tried my own "jackleg" system of "tracing"; I hooked up an outboard power supply that supplied 15vdc, and ran that to the three legs of the circuit card that lined up with the red feeds from the console circuit edge card. Immediately I smelled a burn, and a little smoke from the resistor 2R23. I shut it down quickly. I removed the 2Q7 and tested and found bad readings. Leaving it out, I then added power back and powered up again, trying to touch points on the board to see where I'd see the 15vdc...This led me to pulling at least 2 (may have been three, can't remember at moment) and checking them. Went to parts house to get new stuff, but didn't have it all. I was hoping that replacing these and a couple of others for good measure, that I might just fire it up and see if I had resolved it...but will have to wait until the week to get more parts.

Again, if possible for someone to guide me on how to hook it up, I'd think it might be better to add an outboard small amp to replace it. Just don't know at this point how to wire it...

Thanks for your efforts...


Offline
 Profile Send private message  
 
 Post subject: Re: HELP! This audio amp is getting the better of me...
PostPosted: Mon Oct 07, 2013 5:53 am 
User avatar

Joined: Thu Oct 26, 2006 7:11 pm
Posts: 1295
Location: Maryland
Hi ModRob
Don't take this the wrong way but with your confessed success, it may be a long process. I looked at the schematic, and I assume it is the "Audio Output" board that you are referring to. These boards have a lot of direct coupled semiconductors, and sometimes this creates a domino failure effect. I would suggest that all semiconductors are tested for defects using a decent tester. Front/back ratio's don't always tell the whole story. Look for opens/shorts and gain. Diodes can be tested with some reliability for F/B ratio's but zeners may be a problem. Check all caps for shorts, and resistors for way off values. Yes, that means a lot of desoldering and carefull board work but these are forward steps, not going in circles trying to understand the engineer's concept through the schematics.

As an option, considering that there are only 9 transistors, 10 diodes and a few electrolytic caps, that are really likely to be suspect, shotgun them all, and replace them with exact replacements, or a qualified substiture.

If you are more inclined to try to troubleshoot it, make a board extender, or a harness, so you can get the card out of the cage to work on it while it is powered. A bad or wrong board connection can cause more damage or mislead your efforts. Since there are more than one of these boards shown, you can also do a point to point voltage/resistance comparison to see what that indicates.

I'll be glad to look at the drawings and see of there is a 'simple' means to get around this board with an external amplifier if you think that is the way out of this mess, or maybe I can help in other ways.

In any event, you may want to have the more dense drawings printed in a larger size at the big box office store so you don't go blind, and insane, at the same time :grin:


Len



_________________
Len

“To invent, you need a good imagination and a big pile of junk.” (T. Edison)
"I must be on the way to success since I already have the junk". (Me)
Offline
 Profile Send private message  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron